Wednesday, June 3, 2009

Gmail Growl V1.4

The proxy handling in V1.3 was pretty broken and caused quite a lot of trouble. I am sorry for this.

In Gmail Growl V1.4 the proxy handling is improved in several ways. This should remove the "AutoIt -1" errors and allow all Gmail users to log in, even through company proxies.

In addition, there are the following improvements:

  • New Feature: Configurable Proxy Settings.
  • New Feature: Updates unread mail status now menu entry.
  • Bug Fix: In first time installations, an update was announced although the version was up-to-date.

Download Gmail Growl

All comments, suggestions, feedback, or bug reports are always welcome.

19 comments:

Anthony said...

The update removes the previous error, but now I can't get my credentials accepted even though GG is connected to Gmail. Any suggestions?

Anonymous said...

I too can not get it to recognize my credentials.

Anonymous said...

Idem !!

Mirko

Markus Mohnen said...

Does it work for you with http://dl.getdropbox.com/u/374932/GmailGrowl/gmailgrowl_V1.2.msi?

Savage Alien said...

I still have NOD flagging this and so I can't download it.

Help :(

Markus Mohnen said...

I am sorry, but I haven't found a way to circumvent the false positives of some virus scanners.

Anthony said...

It doesn't work with any version. My credentials are still rejected. I'm running Windows 7 RC 1 if that is important.

Markus Mohnen said...

@Anthony: Can you please retry with V1.4 and run Gmail Growl using the command line

cmd.exe /C "%PROGRAMFILES%\Markus Mohnen\Gmail Growl\gmailgrowl.exe" > %TEMP%\gmailgrowl.log

This will write a log file to %TEMP%\gmailgrowl.log. Please submit this log file using FogBugz https://gmailgrowl.fogbugz.com/default.asp?pg=pgPublicEdit

I can have a closer look at this.

RichK said...

@Markus: I'm getting the same error as Anthony. I've followed your instructions to him and posted a gmailgrowl.log file to the fogbugz site. Case id is 55_he7j

Let me know if I can help you test and thanks again for what promises to be a very cool plug-in

Anthony said...

@Markus I redownloaded the v1.4 msi and now it is working. However, I realize now that I installed in its default location rather than in another location on my C:.

Is it possible that this could have been the problem? Has anyone else done the same thing and came up with the same error?

Markus Mohnen said...

I was able to reproduce the "credentials not accepted" error with the log file from RichK. I hope that I finally found the root cause for this. Please give this a try:
http://dl.getdropbox.com/u/374932/GmailGrowl/gmailgrowl_V1.4.1.msi

RichK said...

@Markus: Confirmed - V1.4.1 fixes the error for me. You rock :) Enjoying this already now...

Anthony said...

I would suggest adding a "Tell Me Again" feature (I believe Digsby has this with its email checking notifications). I tend to be forgetful :-).

Markus Mohnen said...

Tell Me Again sounds good ... I'll add this to the todo list. Thanks!

Peter Guthrie said...

any way I can use this to check both my gmail and google hosted mail at the same time?

Markus Mohnen said...

@Peter Guthrie: Not at this time, but it will do this feature in a future version.

BaNgn BeatZ said...

I have a problem upgrading. I select check for new updates and a notifcation comes up that says, "A new version of Gmail Growl is available. Click to Update" When I click it, it does nothing!

Anonymous said...

With Prowl notification to the iPhone, this is a nice little app. I'd recommend two additions:
1. The ability to display/send only specific information, such as email subject.
2. A link in the notification to the email, maybe compressed with bit.ly.

Ben

Markus Mohnen said...

@Ben: Thanks for the hint to Prowl, this really is cool. I will add some Prowl support.

Post a Comment